Drupal官网Bootstrap基主题文档

简洁、直观、强悍、移动设备优先的前端开发框架,让web开发更迅速、简单。

Drupal Bootstrap 基主题 桥接 Drupal 和 Bootstrap 框架

学习更多关于 Bootstrap 框架

要求

  • jQuery Update - 7.x-2.3 或更高, Bootstrap 要求最小 jQuery 版本1.7 或更高,你在安装该模块后必须手动设置配置

安装

  1. 安装 Bootstrap 基主题在 sites/all/themes 或一个相应 sites/*/themes 文件夹
  2. 确保 jQuery Update 已经配置成最小版本 1.7 或更高

IE 兼容性

Bootstrap 3 不支持旧的IE浏览器兼容模式。要确保你使用IE的最新的渲染模式, 可考虑安装 HTML5 Tools 模块。

使用 Respond.js

 Bootstrap 3 框架要求在IE8上使用 Respond.js 来启用媒体查询 (响应式设计)。然而,Respond.js 并不能通过 @import 引用CSS来工作,当“ CSS 合并”功能未启用时Drupal默认方式是通过该方式引用CSS的。为更好的支持IE8,确保“CSS合并”是启用的。

添加新评论